const regex = new RegExp('(?(DEFINE)
(?<lc>(?=[^a-z\\n]*[a-z])) # lowercase
(?<uc>(?=[^A-Z\\n]*[A-Z])) # uppercase
(?<digit>(?=[^\\d\\n]*\\d)) # digit
(?<special>(?=.*[!@]+)) # special character
)
^(?&lc)(?&uc)(?&digit)(?&special).{6,}$', 'gm')
const str = `ABC123!s
testman
weakpassword
Lmnttmotm1406!
Ab1!!!!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}