#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=\d)[^\d\n]+(?=\d)"
Local $sString = "555a555a5555" & @CRLF & _
"555%555(5555" & @CRLF & _
"5555555855" & @CRLF & _
"555a555~5555" & @CRLF & _
"555 555 5555" & @CRLF & _
"555.555.5555" & @CRLF & _
"555,555,5555" & @CRLF & _
"555(any special char or letter in keyboard here)555(again anything here special char or letter)5555" & @CRLF & _
"555y555-5555" & @CRLF & _
"555/555/5555" & @CRLF & _
"555\555\5555" & @CRLF & _
"555]555[5555" & @CRLF & _
"555~555~5555"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)