$re = '~(?<=\d)[^\d\n]+(?=\d)~';
$str = '555a555a5555
555%555(5555
5555555855
555a555~5555
555 555 5555
555.555.5555
555,555,5555
555(any special char or letter in keyboard here)555(again anything here special char or letter)5555
555y555-5555
555/555/5555
555\\555\\5555
555]555[5555
555~555~5555';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;