import Foundation
let pattern = #"(?<=\d)[^\d\n]+(?=\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
555a555a5555
555%555(5555
5555555855
555a555~5555
555 555 5555
555.555.5555
555,555,5555
555(any special char or letter in keyboard here)555(again anything here special char or letter)5555
555y555-5555
555/555/5555
555\555\5555
555]555[5555
555~555~5555
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)