using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)[^\d\n]+(?=\d)";
string substitution = @"";
string input = @"555a555a5555
555%555(5555
5555555855
555a555~5555
555 555 5555
555.555.5555
555,555,5555
555(any special char or letter in keyboard here)555(again anything here special char or letter)5555
555y555-5555
555/555/5555
555\555\5555
555]555[5555
555~555~5555";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}