using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^interface (\S+)\n?(?:(?: description (.*)| ip address (\S+) (\S+)| .*)\n?)*";
string input = @"interface Null0
no ip unreachables
interface Loopback0
ip address 1.1.1.1 255.255.255.255
no ip redirects
no ip proxy-arp
interface GigabitEthernet0/0/0
description BTCM Hello World
bandwidth 22000
ip address 2.2.2.2 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
interface GigabitEthernet0/0/1
description Interface going to router X
bandwidth 1000000
ip address 3.3.3.3 255.255.255.252
no ip redirects
no ip unreachables";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}