const regex = /^interface (\S+)\n?(?:(?: description (.*)| ip address (\S+) (\S+)| .*)\n?)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^interface (\\S+)\\n?(?:(?: description (.*)| ip address (\\S+) (\\S+)| .*)\\n?)*', 'gm')
const str = `interface Null0
no ip unreachables
interface Loopback0
ip address 1.1.1.1 255.255.255.255
no ip redirects
no ip proxy-arp
interface GigabitEthernet0/0/0
description BTCM Hello World
bandwidth 22000
ip address 2.2.2.2 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
interface GigabitEthernet0/0/1
description Interface going to router X
bandwidth 1000000
ip address 3.3.3.3 255.255.255.252
no ip redirects
no ip unreachables`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}