use strict;
my $str = 'interface Null0
no ip unreachables
interface Loopback0
ip address 1.1.1.1 255.255.255.255
no ip redirects
no ip proxy-arp
interface GigabitEthernet0/0/0
description BTCM Hello World
bandwidth 22000
ip address 2.2.2.2 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
interface GigabitEthernet0/0/1
description Interface going to router X
bandwidth 1000000
ip address 3.3.3.3 255.255.255.252
no ip redirects
no ip unreachables';
my $regex = qr/^interface (\S+)\n?(?:(?: description (.*)| ip address (\S+) (\S+)| .*)\n?)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}