# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^nin)(nin$)/NG/gm;t' <<< "suyunin
abcninshs
ning
gnin
ning
kinindan*
sininteki
nin
ninkisi"