re = /(?!^nin)(nin$)/m
str = 'suyunin
abcninshs
ning
gnin
ning
kinindan*
sininteki
nin
ninkisi'
subst = 'NG'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result