const regex = /(?!^nin)(nin$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^nin)(nin$)', 'gm')
const str = `suyunin
abcninshs
ning
gnin
ning
kinindan*
sininteki
nin
ninkisi`;
const subst = `NG`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);