use strict;
my $str = 'suyunin
abcninshs
ning
gnin
ning
kinindan*
sininteki
nin
ninkisi';
my $regex = qr/(?!^nin)(nin$)/mp;
my $subst = 'NG';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";