import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!^nin)(nin$)";
final String string = "suyunin\n"
+ "abcninshs\n"
+ "ning\n"
+ "gnin\n"
+ "ning\n"
+ "kinindan*\n"
+ "sininteki\n"
+ "nin\n"
+ "ninkisi";
final String subst = "NG";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}