using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)""(?:[^""\\\n]|\\.)*""";
string input = @"""a \"" b""
""a \
b""
""\\""
""\\\
kjsh\a\b\tdfkj\""\\\\\\""
""kjsdhfksd f\\\\""
""kjsdhfksd f\\\""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}