package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)"(?:[^"\\\n]|\\.)*"`)
var str = `"a \" b"
"a \
b"
"\\"
"\\\
kjsh\a\b\tdfkj\"\\\\\\"
"kjsdhfksd f\\\\"
"kjsdhfksd f\\\""
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}