re = /(?s)"(?:[^"\\\n]|\\.)*"/
str = '"a \\" b"
"a \\
b"
"\\\\"
"\\\\\\
kjsh\\a\\b\\tdfkj\\"\\\\\\\\\\\\"
"kjsdhfksd f\\\\\\\\"
"kjsdhfksd f\\\\\\""
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end