import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\"(?:[^\"\\\\\\n]|\\\\.)*\"";
final String string = "\"a \\\" b\"\n"
+ "\"a \\\n"
+ " b\"\n"
+ "\"\\\\\"\n"
+ "\"\\\\\\\n"
+ "kjsh\\a\\b\\tdfkj\\\"\\\\\\\\\\\\\"\n"
+ "\"kjsdhfksd f\\\\\\\\\"\n"
+ "\"kjsdhfksd f\\\\\\\"\"\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}