# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\?\s?/?\n/g;t' <<< "Hi. How are you? What time is it? Beep?"