use strict;
my $str = 'Hi. How are you? What time is it? Beep?';
my $regex = qr/\?\s?/p;
my $subst = '?\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";