#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)=\s*STRING:\s(?|"([^"]*)|([^:]*))"
Local $sString = "dsg.1.2.3.4.5.6.7.5 = STRING: "1234 blah blah blah"" & @CRLF & _
"dsg.1.2.3.4.5.6.7.5 = STRING: 1234 blah blah blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")