import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "=\\s*STRING:\\s(?|\"([^\"]*)|([^:]*))";
final String string = "dsg.1.2.3.4.5.6.7.5 = STRING: \"1234 blah blah blah\"\n"
+ "dsg.1.2.3.4.5.6.7.5 = STRING: 1234 blah blah blah";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}