const regex = /=\s*STRING:\s(?|"([^"]*)|([^:]*))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('=\\s*STRING:\\s(?|"([^"]*)|([^:]*))', 'gm')
const str = `dsg.1.2.3.4.5.6.7.5 = STRING: "1234 blah blah blah"
dsg.1.2.3.4.5.6.7.5 = STRING: 1234 blah blah blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}