$re = '/=\s*STRING:\s(?|"([^"]*)|([^:]*))/m';
$str = 'dsg.1.2.3.4.5.6.7.5 = STRING: "1234 blah blah blah"
dsg.1.2.3.4.5.6.7.5 = STRING: 1234 blah blah blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);