re = /=\s*STRING:\s(?|"([^"]*)|([^:]*))/m
str = 'dsg.1.2.3.4.5.6.7.5 = STRING: "1234 blah blah blah"
dsg.1.2.3.4.5.6.7.5 = STRING: 1234 blah blah blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end