import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n";
final String string = "zoom Account\n"
+ " thomas.quelle@wissens-piloten.de\n"
+ " iJ&US*5X!^A@@2tk9!42\n"
+ " WL - tq@itworks-rahden.de\n\n"
+ " DV\n"
+ " Drohneweg 10\n"
+ " 32369 Rahden\n\n"
+ " NextCloud Austauschordner\n"
+ " https://cloud.wissens-piloten.com/index.php/s/qF79YGHk6Ds9ytX\n"
+ " Passwort: B+ek:=,)iP^=9XM^dV&Y2902\n\n"
+ " Test Von Thomas Q. ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}