# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\n"
test_str = ("zoom Account\n"
" thomas.quelle@wissens-piloten.de\n"
" iJ&US*5X!^A@@2tk9!42\n"
" WL - tq@itworks-rahden.de\n\n"
" DV\n"
" Drohneweg 10\n"
" 32369 Rahden\n\n"
" NextCloud Austauschordner\n"
" https://cloud.wissens-piloten.com/index.php/s/qF79YGHk6Ds9ytX\n"
" Passwort: B+ek:=,)iP^=9XM^dV&Y2902\n\n"
" Test Von Thomas Q. ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.