#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)aaa.+(?=[^}]*dog[^}]*)[^}]+"
Local $sString = " [{" & @CRLF & _
" aaa: true," & @CRLF & _
" some: 'cat goes meow'," & @CRLF & _
" zzz: true" & @CRLF & _
" },{" & @CRLF & _
" aaa: true," & @CRLF & _
" some: 'dog goes woof'," & @CRLF & _
" zzz: true" & @CRLF & _
" }];"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")