import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "aaa.+(?=[^\\}]*dog[^\\}]*)[^\\}]+";
final String string = " [{\n"
+ " aaa: true,\n"
+ " some: 'cat goes meow',\n"
+ " zzz: true\n"
+ " },{\n"
+ " aaa: true,\n"
+ " some: 'dog goes woof',\n"
+ " zzz: true\n"
+ " }];";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}