$re = '/aaa.+(?=[^}]*dog[^}]*)[^}]+/im';
$str = ' [{
aaa: true,
some: \'cat goes meow\',
zzz: true
},{
aaa: true,
some: \'dog goes woof\',
zzz: true
}];';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);