re = /aaa.+(?=[^}]*dog[^}]*)[^}]+/im
str = ' [{
aaa: true,
some: \'cat goes meow\',
zzz: true
},{
aaa: true,
some: \'dog goes woof\',
zzz: true
}];'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end