#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:[wc](?!\w*?[wc])|[og](?!\w*?[og])|[rf](?!\w*?[rf])|[di](?!\w*?[di]))+\b"
Local $sString = "word wrd drow woord wword wordd words sword wosrd" & @CRLF & _
"" & @CRLF & _
"dig wordo crow"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")