re = /\b(?:[wc](?!\w*?[wc])|[og](?!\w*?[og])|[rf](?!\w*?[rf])|[di](?!\w*?[di]))+\b/
str = 'word wrd drow woord wword wordd words sword wosrd
dig wordo crow'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end