$re = '/\b(?:[wc](?!\w*?[wc])|[og](?!\w*?[og])|[rf](?!\w*?[rf])|[di](?!\w*?[di]))+\b/';
$str = 'word wrd drow woord wword wordd words sword wosrd
dig wordo crow';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);