const regex = new RegExp('\\b(?:[wc](?!\\w*?[wc])|[og](?!\\w*?[og])|[rf](?!\\w*?[rf])|[di](?!\\w*?[di]))+\\b', 'g')
const str = `word wrd drow woord wword wordd words sword wosrd
dig wordo crow`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}