using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:[wc](?!\w*?[wc])|[og](?!\w*?[og])|[rf](?!\w*?[rf])|[di](?!\w*?[di]))+\b";
string input = @"word wrd drow woord wword wordd words sword wosrd
dig wordo crow";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}