using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:[0-9]{1,3}\.)){3}[0-9]{1,3}";
string input = @"12.123.12.122okokokko
asodkasdpsodaoskp
oasokapskdaks
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}