re = /^((?:[0-9]{1,3}\.)){3}[0-9]{1,3}/
str = '12.123.12.122okokokko
asodkasdpsodaoskp
oasokapskdaks
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end