$re = '/^((?:[0-9]{1,3}\.)){3}[0-9]{1,3}/';
$str = '12.123.12.122okokokko
asodkasdpsodaoskp
oasokapskdaks
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);