package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:[0-9]{1,3}\.)){3}[0-9]{1,3}`)
var str = `12.123.12.122okokokko
asodkasdpsodaoskp
oasokapskdaks
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}