#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[+-]?(?:(?:\d(?:,(?=\d))?)+(?:\.\d*)?|\.\d+)"
Local $sString = "There are 1,000.5 people in those 3 towns." & @CRLF & _
"1,000 or ,34, or 8,999.09," & @CRLF & _
"3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")