$re = '/[+-]?(?:(?:\d(?:,(?=\d))?)+(?:\.\d*)?|\.\d+)/m';
$str = 'There are 1,000.5 people in those 3 towns.
1,000 or ,34, or 8,999.09,
3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);