import re
regex = re.compile(r"[+-]?(?:(?:\d(?:,(?=\d))?)+(?:\.\d*)?|\.\d+)", flags=re.MULTILINE)
test_str = ("There are 1,000.5 people in those 3 towns.\n"
"1,000 or ,34, or 8,999.09,\n"
"3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")