using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[+-]?(?:(?:\d(?:,(?=\d))?)+(?:\.\d*)?|\.\d+)";
string input = @"There are 1,000.5 people in those 3 towns.
1,000 or ,34, or 8,999.09,
3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}