re = /[+-]?(?:(?:\d(?:,(?=\d))?)+(?:\.\d*)?|\.\d+)/m
str = 'There are 1,000.5 people in those 3 towns.
1,000 or ,34, or 8,999.09,
3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end