# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?\|){2}|(\|[^|]*){2}$//gm;t' <<< "One-1|two-2|Three-3|Four-4|Five-5
Six-6|Seven-7|Eight-8|Nine|Ten-10
Eleven-11|Twelve-12|Thirteen-13|Fourteen-14|Fifteen-15
Sixteen-16|Seventeen-17|Eighteen-18|Nineteen-19|Twenty-20"