$re = '/^(.*?\|){2}|(\|[^|]*){2}$/m';
$str = 'One-1|two-2|Three-3|Four-4|Five-5
Six-6|Seven-7|Eight-8|Nine|Ten-10
Eleven-11|Twelve-12|Thirteen-13|Fourteen-14|Fifteen-15
Sixteen-16|Seventeen-17|Eighteen-18|Nineteen-19|Twenty-20';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;