# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*?\|){2}|(\|[^|]*){2}$"
test_str = ("One-1|two-2|Three-3|Four-4|Five-5\n"
"Six-6|Seven-7|Eight-8|Nine|Ten-10\n"
"Eleven-11|Twelve-12|Thirteen-13|Fourteen-14|Fifteen-15\n"
"Sixteen-16|Seventeen-17|Eighteen-18|Nineteen-19|Twenty-20")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.