#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "#foo(?=\s|$)"
Local $sString = "#foo #foo #foo"
Local $sSubst = "#bar"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)