$re = '/#foo(?=\s|$)/';
$str = '#foo #foo #foo';
$subst = "#bar";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;