const regex = /#foo(?=\s|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#foo(?=\\s|$)', 'g')
const str = `#foo #foo #foo`;
const subst = `#bar`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);